Google Outage preventing some Logins to Clever

Incident Report for Clever

Resolved

This incident has been resolved.
Posted Sep 19, 2025 - 08:43 PDT

Monitoring

Google confirmed that a fix has been implemented for this issue. However, we are monitoring the success of impacted Districts.
Posted Sep 18, 2025 - 13:26 PDT

Identified

Google, used to login to Chromebooks and Clever for many districts, is experiencing an outage. This is preventing some users from being able to login to Clever via Google. We are monitoring the issue and will provide status updates as they become available from Google.
Posted Sep 18, 2025 - 08:29 PDT
This incident affected: Single Sign-On.