STLs receiving an error when accessing user accounts
Incident Report for Clever
Resolved
We have resolved this issue, and everything is back to normal. If you see any additional issues, please contact Clever Support through our Help Center: support.clever.com.
Posted Jan 08, 2025 - 14:32 PST
Investigating
Clever is experiencing an issue where STLS are receiving an error when trying to access student or teacher accounts from the District Dashboard. This is preventing STLs from accessing student and teacher accounts. We are investigating the issue and will provide regular status updates.
Posted Jan 08, 2025 - 08:03 PST
This incident affected: District Administration Dashboard.