Clever Support: Phone service outage

Incident Report for Clever

Resolved

This incident has been resolved.
Posted Jul 09, 2025 - 15:46 PDT

Monitoring

Mitigation measures were applied by our provider and we are seeing system recovery for phones.
Posted Jul 09, 2025 - 15:38 PDT

Identified

Clever Support's phone provider is experiencing service issues. We are monitoring the service outage and will provide regular status updates. In the meantime, please submit all support requests via our web form at support.clever.com to ensure our team receives your request.
Posted Jul 09, 2025 - 15:24 PDT
This incident affected: Support.