Clever school search bar errors
Incident Report for Clever
Resolved
This incident has been resolved.
Posted Aug 17, 2020 - 07:38 PDT
Monitoring
A fix has been implemented, and we are monitoring the results.
Posted Aug 17, 2020 - 07:24 PDT
Investigating
The Clever school search bar is experiencing intermittent errors. As a workaround, navigate directly to your district's Clever login URL, e.g. https://clever.com/in/{districtShortname}.
Posted Aug 17, 2020 - 07:05 PDT
This incident affected: Single Sign-On.