Application and Links in Clever Portal Display "This link will open in a new window"
Incident Report for Clever
Resolved
We have resolved this issue, and everything is back to normal. If you see any additional issues, please contact Clever Support through our Help Center: support.clever.com.
Posted Nov 15, 2021 - 07:01 PST
Investigating
The Clever Portal is experiencing an issue that displays a message stating "This link will open in a new window" for all applications and links for all users. This message should not be causing any navigation issues when accessing your applications and links within the Clever Portal. We are investigating the issue and will provide regular status updates. In the meantime, please continue to access your applications and links within the Clever Portal as normal.
Posted Nov 15, 2021 - 05:17 PST
This incident affected: District Administration Dashboard.