clever.com website is intermittently unavailable
Incident Report for Clever
Resolved
We’ve addressed the issue, and the clever.com website is operating as normal. If you notice any further issues, please reach out at support.clever.com.
Posted Dec 13, 2021 - 18:24 PST
Monitoring
We’ve addressed the issue, and the clever.com website should be operating as normal. We’ll continue to monitor for further errors and notify once the incident is completely resolved.
Posted Dec 13, 2021 - 18:21 PST
Identified
We’ve identified the error causing the clever.com website to experience intermittent errors on loading and are working on a resolution.

You can still log into your Clever account by navigating to clever.com/login. For any questions, please visit support.clever.com

We’re sorry for the inconvenience and will notify when the website is operating as normal. Thank you for your patience!
Posted Dec 13, 2021 - 17:41 PST