Skyward Selenium Sync Issue

Incident Report for Clever

Resolved

Our Engineering team was able to identify and resolve the issue regarding Skyward Selenium syncs failing for some districts. Those impacted districts should see those previously failed syncs run. For any further questions regarding your impacted sync, please contact our Support Team at support.clever.com

Thank you and we apologize again for any inconvenience this may have caused.
Posted Mar 18, 2026 - 10:00 PDT

Investigating

There is a sync issue for some districts on the Skyward Selenium sync that is preventing syncs from being completed. At this time we are investigating the issue and will provide regular status updates. We apologize for the inconvenience this may cause.
Posted Mar 18, 2026 - 07:51 PDT
This incident affected: SIS Sync (Skyward).