Clever Support: Phone service outage
Incident Report for Clever
Resolved
Clever Support's phone provider has resolved the outage and phone service is restored. If you encounter any issues, please submit a support request with our team at support.clever.com.
Posted Sep 08, 2022 - 09:54 PDT
Identified
Clever Support's phone provider is experiencing service issues. We are monitoring the service outage and will provide regular status updates. In the meantime, please submit all support requests via our web form at support.clever.com to ensure our team receives your request!
Posted Sep 08, 2022 - 09:36 PDT
This incident affected: Support.