Google experiencing an Outage
Incident Report for Clever
Resolved
Google has resolved the issue, and everything is back to normal. If you experience any additional issues, please contact Clever Support through our Help Center: support.clever.com.
Posted Mar 05, 2024 - 09:40 PST
Identified
Google, a service that works with Clever, is experiencing an outage at the moment. This is impacting some districts ability to log into Clever and accessing other applications within Clever. We are monitoring the issue and will provide status updates as they become available from Google.
Posted Mar 05, 2024 - 08:24 PST
This incident affected: Single Sign-On.