PowerSchool Plugin 401 Error

Incident Report for Clever

Resolved

Districts syncing to Clever via the PowerSchool Plugin are hitting a 401 installation error. Our team is currently investigating the issue. As a current workaround, districts can resolve the issue by deleting the old plugin and reinstall an updated version.

To resolve the error on your PowerSchool Plugin sync, please follow these steps:

1. Delete the existing plugin from PowerSchool on your Plugin Management page.
2. Download the latest version of the plugin for your Clever sync from the Sync > Settings page of your Clever Dashboard.
3. Re-install the plugin from scratch using the instructions available here: https://support.clever.com/hc/s/articles/000001590?language=en_US#setup
Posted Apr 10, 2025 - 09:40 PDT

Identified

We learned PowerSchool recently made changes as part of ongoing server upgrades which impacted the credentials used by the PowerSchool plugin. These credentials are now likely invalid, which means districts on the PowerSchool Plugin sync are not working as expected.

What you need to do as soon as possible to restore your sync:

1. Delete the existing Clever plugin from your PowerSchool Plugin Management page.
2. Download the latest version of the plugin from the Sync > Settings page in your Clever Dashboard. This will generate new credentials and securely share them with Clever.
3. Re-install the plugin using these instructions.

Clever has sent out an email to all impacted districts. If you have any questions, please reach out to us at support.clever.com
Posted Apr 09, 2025 - 08:33 PDT

Investigating

Districts syncing to Clever via the PowerSchool Plugin are hitting a 401 installation error. Our team is currently investigating the issue. As a current workaround, districts can resolve the issue by deleting the old plugin and reinstall an updated version.

To resolve the error on your PowerSchool Plugin sync, please follow these steps:

1. Delete the existing plugin from PowerSchool on your Plugin Management page.
2. Download the latest version of the plugin for your Clever sync from the Sync > Settings page of your Clever Dashboard.
3. Re-install the plugin from scratch using the instructions available here: https://support.clever.com/hc/s/articles/000001590?language=en_US#setup

We apologize for the inconvenience and will be posting updates as soon as we can.
Posted Apr 07, 2025 - 09:06 PDT
This incident affected: SIS Sync (Powerschool).