Downtime for District Administrator Dashboard
Incident Report for Clever
Resolved
This incident has been resolved.
Posted Mar 19, 2020 - 12:55 PDT
Investigating
The district administrator dashboard is experiencing downtime. Users are unable to view or interact with the dashboard. We are currently investigating this issue.
Posted Mar 19, 2020 - 12:16 PDT
This incident affected: District Administration Dashboard.