Clever Admin Deletion Error and Clever Account Email

Incident Report for Clever

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 19, 2025 - 07:01 PST

Investigating

Clever recently encountered an error resulting in some Clever syncs going on hold due to admin deletions. We have resolved this issue, and are monitoring. If your sync is currently on hold, do not approve the hold.

If you received a 'Create your Clever Account' email, it means your admin account was deleted and recreated as a result of this issue. As a next step, please follow the steps in the email to recreate your account with Clever.

For any questions or assistance, please reach out to Clever Support at support.clever.com

We sincerely apologize for any inconvenience this may cause and thank you for your patience.
Posted Nov 19, 2025 - 07:01 PST