Clever Sync Page Issues

Incident Report for Clever

Resolved

The issue with the Sync page not loading or displaying data changes has been resolved. If you are still unable to view recent data changes from your Sync page, please refresh your browser. We apologize any inconvenience this may have caused. Please reach out to Clever Support if you are still having issues viewing your data: support.clever.com

Thank you
Posted Sep 26, 2025 - 07:42 PDT

Investigating

We are currently investigating an issue that is causing issues with the Sync page not loading or not allowing a District Admin to view recent data changes. As soon as we have a resolution, we will update this page. We apologize for the inconvenience this may be causing.
Posted Sep 26, 2025 - 06:23 PDT
This incident affected: District Administration Dashboard.