Clever Website providing Error Messages
Incident Report for Clever
Resolved
We have resolved this issue, and everything is back to normal. If you see any additional issues, please contact Clever Support through our Help Center: support.clever.com.
Posted Jan 08, 2024 - 14:04 PST
Update
We have resolved this issue, and everything is back to normal. If you see any additional issues, please contact Clever Support through our Help Center: support.clever.com.
Posted Jan 08, 2024 - 13:56 PST
Investigating
Clever is experiencing an issue with pages on the clever.com website, however the login button at the top of the page is operational.
Our website pages are providing an error message. We are investigating the issue and will provide regular status updates.

Please note that all of our services and logins are operational as they have not been impacted by this issue.
Posted Jan 08, 2024 - 12:11 PST
This incident affected: District Administration Dashboard and Apps Dashboard.