Clever Portal Issue
Incident Report for Clever
Resolved
The issue with Clever Admins not being able to access their Clever Portal has now been resolved. All users should be able to access their Clever Portal. Please contact Clever Support at support.clever.com if you are still having issues. Thank you for your patience!
Posted Oct 25, 2024 - 07:31 PDT
Investigating
Clever is currently experiencing an issue with Clever Admins accessing their Clever Portal from their Dashboard. It does not appear to be impacting students and teachers from accessing their Clever Portals. We are currently investigating the issue and will provide regular status updates.
Posted Oct 25, 2024 - 06:11 PDT
This incident affected: Single Sign-On.