Deleted Section Data for PowerSchool Districts

Incident Report for Clever

Resolved

The issue has been resolved and everything is back to normal. If you experience any additional issues, please contact Clever Support through our Help Center at support.clever.com.
Posted Apr 24, 2023 - 15:37 PDT

Investigating

Clever is actively investigating reports of deleted section data for PowerSchool districts. We’re investigating the issue and will provide regular status updates.
Posted Apr 24, 2023 - 09:29 PDT
This incident affected: SIS Sync (Powerschool).