Some districts unable to log into Clever
Incident Report for Clever
Resolved
We have resolved the log in issue and sincerely apologize for any inconvenience this may have caused. If you see any additional issues, please contact Clever Support through our Help Center: support.clever.com.
Posted Apr 06, 2023 - 13:37 PDT
Update
Our Engineering team has implemented a fix to the login issue and we are going to continue monitor the situation. If you are still unable to log into your Clever account or access certain applications from your Clever account, please reach out to our Support team and submit a ticket at support.clever.com
Posted Apr 06, 2023 - 11:16 PDT
Monitoring
Our Engineering team has identified the issue and we are seeing login error rates subside as we continue to monitor the situation. Please note some users who are able to log into Clever may not have access to certain applications at this time while the issue continues to be resolved.

Thank you for your continued patience and we will continue to provide updates on the status of this issue.
Posted Apr 06, 2023 - 10:47 PDT
Update
Update: We are still experiencing districts unable to log into Clever. Our Engineering team is still actively working on resolving this issue. Thank you for your patience and we will continue to provide more updates.
Posted Apr 06, 2023 - 07:39 PDT
Investigating
We are aware that some districts are unable to log into Clever. We are currently investigating the situation and apologize for any inconvenience this is causing. We will provide updates as soon as they are available.
Posted Apr 06, 2023 - 06:05 PDT
This incident affected: Single Sign-On.