Clever Support: Phone service outage

Incident Report for Clever

Resolved

We have resolved this issue, and everything is back to normal. If you see any additional issues, please contact Clever Support through our Help Center: support.clever.com.
Posted Dec 08, 2022 - 07:49 PST

Monitoring

We believe we have addressed the issue and our phone support line should be operating as normal. We will continue to monitor for further issues and provide an update once the incident is completely resolved.
Posted Dec 08, 2022 - 07:34 PST

Update

We are continuing to investigate this issue.
Posted Dec 08, 2022 - 06:36 PST

Investigating

Clever Support's phone provider is experiencing service issues. We are monitoring the service outage and will provide regular status updates. In the meantime, please submit all support requests via our web form at support.clever.com to ensure our team receives your request!
Posted Dec 08, 2022 - 06:36 PST
This incident affected: Support.