Teacher Homepage Error
Incident Report for Clever
Resolved
We have resolved this issue, and everything is back to normal. If you see any additional issues, please contact Clever Support through our Help Center: support.clever.com.
Posted Mar 21, 2023 - 09:06 PDT
Investigating
Clever is experiencing an error for teachers when trying to access the homepage of the Portal. We’re investigating the issue and will provide regular status updates.
Posted Mar 21, 2023 - 08:47 PDT
This incident affected: District Administration Dashboard.