Clever Academy service outage
Incident Report for Clever
Resolved
This incident has been resolved. If you encounter any issues with Clever Academy, please contact our team at support.clever.com
Posted Feb 24, 2022 - 10:04 PST
Monitoring
Clever Academy is now operational. We are continuing to monitor.
Posted Feb 24, 2022 - 09:43 PST
Identified
The platform provider for Clever Academy is currently experiencing issues. As a result, The Clever Academy website and courses are currently unavailable. We are monitoring the situation and will provide updates as available.
Posted Feb 24, 2022 - 08:51 PST