Clever Password Login Errors
Incident Report for Clever
Resolved
Our team has identified and resolved the issue impacting logging in with Clever Passwords. All affected districts will now be able to log in.

If your district has any additional issues with Clever Passwords, please contact Clever Support us at support.clever.com.
Posted 5 months ago. Feb 01, 2019 - 12:14 PST
Monitoring
Our team has implemented a fix and Single Sign On is now functional for students and teachers using Clever Passwords. If your district encounters login issues with Clever Passwords, please contact us at support.clever.com

We will continue to monitor the issue and will provide regular status updates.
Posted 5 months ago. Feb 01, 2019 - 09:40 PST
Investigating
Single Sign On is experiencing downtime for some students and teachers using Clever Passwords. This is preventing users from logging into the Clever Portal with Clever Passwords. We're investigating the issue and will provide regular status updates.
Posted 5 months ago. Feb 01, 2019 - 08:11 PST
This incident affected: Single Sign-On.