Data not loading in App Dashboard

Incident Report for Clever

Resolved

We have resolved this issue, and everything is back to normal. If you see any additional issues, please contact Clever Support through our Help Center: support.clever.com.
Posted Aug 05, 2025 - 12:32 PDT

Identified

Clever is experiencing an issue where data will not load or update within the App Dashboard. We have identified the error causing the issue and are working on a resolution. We are sorry for the issue and will provide an update when App Dashboard is operating as normal. Thank you for your patience.
Posted Aug 05, 2025 - 11:51 PDT
This incident affected: Apps Dashboard.