Users are experiencing issues logging into the Clever Portal
Incident Report for Clever
Resolved
This issue has been resolved, and everything is back to normal. If you see any additional issues, please contact Clever Support through our Help Center: support.clever.com.
Posted 5 months ago. Apr 04, 2019 - 20:29 PDT
Monitoring
Our team has implemented a fix and are no longer seeing any errors. We are continuing to monitor our changes to ensure all issues have been resolved.
Posted 5 months ago. Apr 04, 2019 - 20:13 PDT
Investigating
We are investigating increased error rates while loading the Clever Portal.
Posted 5 months ago. Apr 04, 2019 - 20:01 PDT
This incident affected: Single Sign-On.