Clever Portal Working
Incident Report for Clever
Resolved
The Clever Portal is now working and all users should be able to login to Clever. This incident has been resolved.
Posted Sep 13, 2023 - 12:20 PDT
Monitoring
The Clever Portal is now working and all users should be able to login to Clever. We apologize for the inconvenience and our teams will continue to monitor the situation. If you are still experiencing login issues, please reach out to Clever Support at support.clever.com
Posted Sep 13, 2023 - 08:12 PDT
Update
The Clever Portal is currently down for all users. Our teams are still investigating the issue and we will provide status updates as soon as they are available.
Posted Sep 13, 2023 - 07:13 PDT
Update
We are continuing to investigate this issue.
Posted Sep 13, 2023 - 07:06 PDT
Investigating
The Clever Portal is currently down for all users. Our teams are still investigating the issue and we will provide status updates as soon as they are available. We sincerely apologize for the inconvenience.
Posted Sep 13, 2023 - 06:00 PDT
This incident affected: Single Sign-On.