Clever Support / Help Center Unavailable
Incident Report for Clever
Resolved
Services have been restored by our helpdesk provider. We will continue to monitor services through the upcoming days to ensure the stability of support access for our customers.
Posted Aug 08, 2023 - 20:19 PDT
Monitoring
Clever's helpdesk provider is stabilizing services and access to support.clever.com is restored. We continue to monitor the incident to ensure stable access to Clever's support services. https://status.salesforce.com/generalmessages/1168
Posted Aug 08, 2023 - 19:55 PDT
Update
Clever's helpdesk provider is still investigating the outage impacting support.clever.com and our helpdesk platform. We continue to monitor the situation and apologize for the interruption: https://status.salesforce.com/generalmessages/1168
Posted Aug 08, 2023 - 19:07 PDT
Identified
Clever's helpdesk provider is experiencing a full outage impacting access to support.clever.com. Our team is monitoring the situation and will provide updates as information becomes available.
Posted Aug 08, 2023 - 18:15 PDT
This incident affected: Support.