Application Dashboard is down
Incident Report for Clever
Resolved
The Application Dashboard is now loading appropriately. This issue has been resolved. Thank you for your patience!
Posted Jul 29, 2021 - 05:47 PDT
Investigating
The Application Dashboard is experiencing blank pages when initially logging into the account. We are investigating the issue and will provide regular updates. In the meantime, you can try refreshing the browser if the Application Dashboard is blank upon logging as this has resolved the issue for some.
Posted Jul 29, 2021 - 05:24 PDT
This incident affected: Apps Dashboard.