Scheduled Maintenance for Clever Messaging
Incident Report for Clever
Resolved
Maintenance on Clever Messaging is complete and all messaging features are fully functional. Please reach out to our Support Team if you have any questions.
Posted Jul 11, 2022 - 13:58 PDT
Investigating
Clever is enhancing the infrastructure underlying Clever Messaging. We are scheduling maintenance from 8pm-4am PST from June 27th through July 8th.

During the scheduled maintenance blocks, Clever Messaging will not be available. We are sorry for the inconvenience. Please reach out to our Support Team if you have any questions.
Posted Jun 28, 2022 - 07:26 PDT
This incident affected: District Administration Dashboard.