District-Admin Endpoint not Returning Data

Incident Report for Clever

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 02, 2025 - 12:51 PDT

Investigating

Clever is currently experiencing an issue where the district-admin endpoint is not returning data for some districts. In addition, this may be leading to a subset of District Admins not being able to access some learning applications. We are currently investigating this issue and will provide prompt updates when we have them!
Posted Jul 02, 2025 - 10:45 PDT
This incident affects: Rostering API (Data API) and Single Sign-On.