Clever Support currently unavailable
Incident Report for Clever
Resolved
The issue has been resolved, and Clever Support is available via support.clever.com and phone calls during business hours (7am-8pm ET, Monday-Friday).
Posted May 11, 2021 - 17:26 PDT
Investigating
We have identified an issue with our Help Center and Help Desk platform availability. This is preventing the ability to submit new support cases and the ability to call our support team. Our team is investigating with our platform provider, and will provide updates as available.
Posted May 11, 2021 - 15:31 PDT
This incident affected: Support.