Clever Portal Login Issues
Incident Report for Clever
Resolved
This issue was resolved and everything is back to normal. If you see any additional issues, please contact Clever Support through our Help Center: support.clever.com.
Posted Oct 18, 2024 - 13:44 PDT
Update
Our Engineering team recently released a fix for this issue and we are currently monitoring the situation. Thank you for your continued patience!
Posted Oct 18, 2024 - 08:02 PDT
Investigating
Clever is currently experiencing an issue with users accessing Clever via the Clever Portal. This is preventing users from being able to login and access Clever. We are currently investigating the issue and will provide regular status updates.
Posted Oct 18, 2024 - 06:56 PDT
This incident affected: Single Sign-On.