Clever Portal Announcement Issues for Teachers
Incident Report for Clever
Resolved
We have resolved this issue, and everything is back to normal. If you see any additional issues, please contact Clever Support through our Help Center: support.clever.com.
Posted Nov 26, 2024 - 11:54 PST
Identified
Clever has identified the root cause of the issue with Announcements not loading for teachers in the Clever Portal. We will continue to monitor the issue until fully resolved and will provide regular status updates.
Posted Nov 26, 2024 - 10:17 PST
Investigating
Clever is currently experiencing an issue where Announcements in the Clever Portal are not loading for teachers. We are investigating the issue and will provide regular status updates.
Posted Nov 26, 2024 - 09:16 PST