Saved Password application errors

Incident Report for Clever

Resolved

This incident has been resolved.
Posted May 09, 2023 - 13:01 PDT

Investigating

Clever has identified an issue with some Saved Password applications directing users to the incorrect school URL. We are currently investigating and will provide updates as soon as they are available.
Posted May 09, 2023 - 12:42 PDT
This incident affected: Single Sign-On.