Clever login issues

Incident Report for Clever

Resolved

This incident has been resolved.
Posted Nov 13, 2023 - 08:41 PST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 13, 2023 - 08:04 PST

Identified

“The Clever Portal is currently down for some users. Our teams are still investigating the issue and we will provide status updates as soon as they are available. We sincerely apologize for the inconvenience.”
Posted Nov 13, 2023 - 06:22 PST
This incident affected: Single Sign-On.