Google has resolved this issue, and everything is back to normal. Please update to the ChromeOS 139 version.
Posted Aug 28, 2025 - 16:17 PDT
Identified
Google, a service that works with Clever, is experiencing issues with users being unable to login using their Google credentials for those who updated to ChromeOS 139. This is preventing users from being able to login to their Clever account. We are monitoring the issue and will provide status updates as they become available.
In the meantime, we advise rolling back to either ChromeOS 138 or earlier until this issue is resolved.
Posted Aug 26, 2025 - 14:28 PDT
Investigating
Google, a service that works with Clever, is experiencing issues with users being unable to login using their Google credentials for those who updated to ChromeOS 139. This is preventing users from being able to login to their Clever account. We are monitoring the issue and will provide status updates as they become available.