Mailchimp Transactional email disruption
Incident Report for Clever
Resolved
This issue has been resolved, and we've made efforts to resend any emails that were skipped. If you see any additional issues, please contact Clever Support through our Help Center: support.clever.com.
Posted Jan 10, 2023 - 17:53 PST
Monitoring
Mailchimp Transactional (Mandrill), a service that partners with Clever, experienced connection errors for some users on Wednesday, January 4th. This prevented some automated emails from being sent. Service is in the process of being restored, and we will provide status updates as they become available from Mailchimp. Once resolved, we will make efforts to resend any missed emails. In the meantime, if you are missing an automated email feel free to try that action again.
Posted Jan 04, 2023 - 18:22 PST