Clever Support Experiencing Issues
Incident Report for Clever
Resolved
The issue has been resolved and Clever Support is no longer impacted. Our support agents will be responding to all support requests and working towards resolving any tickets that were opened during the impacted time. We apologize for any inconvenience this may have caused and thank you for your patience!
Posted Feb 24, 2022 - 06:52 PST
Investigating
Clever Support is experiencing an issue that is impacting our ability to support our customers. This may cause a delay in the response time and/or resolution to your support request. Our team is working to resolve the issue and will provide regular status updates! In the meantime, you can still access our Help Site at support.clever.com to troubleshoot your issue or submit a ticket to Clever Support.

We apologize for any inconvenience this may cause and will be updating our status page as new developments arise. Thank you!
Posted Feb 24, 2022 - 05:54 PST
This incident affected: Support.