District Admins unable to adjust sharing permissions for connected apps
Incident Report for Clever
Resolved
This incident has been resolved.
Posted Jan 30, 2025 - 09:06 PST
Identified
The issue has been identified and a fix is being implemented.
Posted Jan 30, 2025 - 07:41 PST
Investigating
Clever is experiencing issues with District Administrators' attempts to adjust their sharing permissions. We’re investigating the issue and will share updates on our status page (status.clever.com). We’re sorry for the inconvenience and thank you for your patience!
Posted Jan 30, 2025 - 07:30 PST
This incident affected: District Administration Dashboard.