Clever login page downtime
Incident Report for Clever
Resolved
We have identified and resolved the issue that caused the Clever login page outage. The Clever Portal should be operating as normal. If you see any additional issues, please contact Clever Support through our Help Center: support.clever.com.
Posted 7 months ago. Feb 26, 2019 - 15:50 PST
Monitoring
Some users may have been unable to access the Clever Portal login page for a brief period of time. We have mitigated the errors and the Clever Portal should now be operating as normal. We will continue to investigate the errors and notify once the incident is completely resolved.
Posted 7 months ago. Feb 26, 2019 - 13:07 PST
This incident affected: Single Sign-On.