Clever Goals login issues
Incident Report for Clever
Resolved
We have resolved the student login issue in districts who have purchased Clever Goals.
Posted 3 months ago. Sep 14, 2018 - 06:49 PDT
Investigating
We are investigating reports from districts who have purchased Clever Goals around issues with student logins.
Posted 3 months ago. Sep 14, 2018 - 06:36 PDT
This incident affected: Goals.