Intermittent Errors within Clever

Incident Report for Clever

Resolved

We have resolved this issue, and everything is back to normal. If you see any additional issues, please contact Clever Support through our Help Center: support.clever.com.
Posted Sep 26, 2024 - 13:37 PDT

Monitoring

The intermittent errors within the Clever product for all user types is beginning to subside. We will continue to monitor the issue until fully resolved and will provide regular status updates.
Posted Sep 26, 2024 - 09:53 PDT

Investigating

Clever is experiencing intermittent errors within the Clever product for all user types. We’re investigating the issue and will provide regular status updates.
Posted Sep 26, 2024 - 09:16 PDT
This incident affected: District Administration Dashboard.