The district administration dashboard is having intermittent issues
Incident Report for Clever
Resolved
This incident has been resolved.
Posted 9 days ago. Jul 11, 2019 - 23:05 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted 9 days ago. Jul 11, 2019 - 19:53 PDT
Investigating
We are currently investigating this issue.
Posted 9 days ago. Jul 11, 2019 - 18:23 PDT
This incident affected: District Administration Dashboard.