Users unable to login to Clever due to Amazon AWS issue

Incident Report for Clever

Identified

Amazon AWS, a service that works with Clever, is experiencing a issue that is preventing users from being able to log in to Clever. We are monitoring the issue and will provide status updates as they become available.
Posted Feb 10, 2026 - 13:25 PST

Investigating

Clever is currently investigating an issue where clever.com/login is inaccessible. As soon as we have more information, we will provide an update.
Posted Feb 10, 2026 - 12:47 PST
This incident affects: Single Sign-On.