District Admins Unable to Access Downloaded Badges from Email

Incident Report for Clever

Resolved

Our Engineering team found the root cause of the issue regarding District Admins getting an error message when trying to access downloaded Clever Badges from their email and has released a fix for this.

District Admins should now be able to download badges from their email. Please contact support at support.clever.com if you need further assistance!

We apologize again for any inconvenience this may have caused.
Posted Aug 12, 2025 - 13:07 PDT

Investigating

We are currently investigating the issue regarding District Admins getting an error message when trying to access downloaded Clever Badges from their email. We apologize for any inconvenience this is causing and will update this page as we work to resolve this issue.
Posted Aug 12, 2025 - 11:57 PDT
This incident affected: Single Sign-On.