Clever Dashboard Experiencing Intermittent Loading Errors
Incident Report for Clever
Resolved
The issue has been resolved, and the Clever Dashboard is now loading as expected. If you encounter further issues, please reach out to us at support.clever.com.
Posted Dec 14, 2021 - 18:13 PST
Investigating
The Clever Dashboard is experiencing intermittent loading errors. We are currently investigating and will continue to provide regular status updates.
Posted Dec 14, 2021 - 09:55 PST
This incident affected: District Administration Dashboard.