Google logins failing with error in mobile applications
Incident Report for Clever
Resolved
This incident has been resolved.
Posted Jun 12, 2017 - 14:52 PDT
Monitoring
Google is preventing OAuth flows in webviews - if a user attempts to log in to Clever via Google in a mobile application that's using webviews, they'll see a "disallowed_useragent" error message. For users on iOS, this only impacts users on iOS 9.0+; users on devices running versions of iOS prior to 9.0 will continue to be able to log in as usual.

To resolve this issue in iOS, use SFSafariViewController iOS 9.0+ or use Clever's iOS SDK. For Android, redirect the user to the browser instead of using a webview.
Posted May 11, 2017 - 11:41 PDT