Clever site returning a 502 error
Incident Report for Clever
Resolved
We have resolved this issue, and everything is back to normal. If you see any additional issues, please contact Clever Support through our Help Center: support.clever.com.
Posted Sep 20, 2023 - 10:05 PDT
Monitoring
We have addressed the issue, and www.clever.com should be operating as normal. We’ll continue to monitor for further errors and notify once the incident is completely resolved.
Posted Sep 20, 2023 - 09:32 PDT
Investigating
We are experiencing an issue with our www.clever.com site. This is providing a 502 error preventing users from being able to access the site. We’re investigating the issue and will provide regular status updates. In the meantime, please navigate to www.clever.com/login to access Clever.
Posted Sep 20, 2023 - 08:45 PDT
This incident affected: Single Sign-On.