Teacher pages are unavailable for students
Incident Report for Clever
Resolved
This issue has been resolved, and everything is back to normal. If you see any additional issues, please contact Clever Support through our Help Center: support.clever.com.
Posted Dec 13, 2019 - 07:07 PST
Investigating
We are experiencing an issue that is preventing students from being able to access their Teacher Pages on the Clever Portal. Students and teachers are still able to access applications from their district Portal pages. We’re investigating the issue and will provide status updates.
Posted Dec 13, 2019 - 06:49 PST
This incident affected: Single Sign-On.