District admins unable to access the Clever Portal
Incident Report for Clever
Resolved
This incident has been resolved.
Posted about 1 month ago. Jun 18, 2019 - 13:24 PDT
Monitoring
District admins are again able to access the Clever Portal. We apologize for any inconveniences this may have caused!
Posted about 1 month ago. Jun 18, 2019 - 13:20 PDT