Intermittent issues on school search page
Incident Report for Clever
Resolved
This issue has been resolved, and everything is back to normal. If you see any additional issues, please contact Clever Support through our Help Center: support.clever.com.
Posted Mar 30, 2020 - 10:45 PDT
Investigating
We are experiencing errors for some users when using the school search on the Clever login page. Users are still able to log into the Clever Portal via their district-specific URL. Our engineering team is investigating now.
Posted Mar 30, 2020 - 09:28 PDT